Products » Knowledge Base » Url Master 

Url Master Help Wiki

Url Master 404 Errors

A 404 error is a reasonably common occurence on a new installation of the Url Master module.

In general the first check is to make sure the Url is valid, the module is installed correctly, and, if possible, whether the Url will work with the standard DNN Url Rewriter and only fails with the Url Master module installed and configured.

This short troubleshooting guide will help step you through a process to find out why you might be getting a 404 errror.

- Check the module is activated

Open up the web.config file, and search for the string 'ifinity.urlmaster'.  If you find entries in the httpModules, modules and friendyUrl  sections, then the module has been activated OK.  If not, re-try clicking the 'apply changes' button and consider manually applying the settings.  The process on manually configuring settings is in the instructions file.

- Check the portal aliases

Unlike the standard DNN Url Rewriter, the Url Master module doesn't assume that the site is active for both the www and non-www versions of your domain name.  You must enter both and into the list of portal aliases if you wish the site to work with both domains.  This is required whether or not you're using domain redirection to force to www or non-www.  Restart your website after adding the missing portal alias if you find one of them missing.

- Check the 'Friendly Url Settings' checkbox.

As a module that mimics the standard DNN Friendly Url Provider where possible, the Url Master module takes note of the setting in the 'Friendly Url Settings' section of the 'Host Settings' page.  In this section, there is a checkbox for activating friendly urls on the site.  If this is not checked, then the Url Master will not generate Friendly Urls for all of the portals on the installation.

- Check the 'Advanced Regex Settings'

In the Friendly Url Settings page, there is a section called 'Advanced Regex Settings'.  Within this section are a series of Regex expressions, which filter out requests entirely, or just stop the requests from being rewritten or redirected.  Check to see that your Url with the 404 error is not matching against one of these regex filters.  This might be the case if you're using a non-standard page extension like .html (excluded by default) or if you have modified the regex patterns and accidentally filtered out valid urls (such as adding in .aspx into the 'ignoreRegex' field).

If you do not know how to use Regex, you can still find tools to put a regex expression into a field, and then compare it with a text input (the url that doesn't work)- if you get a match, the regex filter is 'catching' that Url.

- Check for Unwanted Redirects

The Url Master module has a lot of powerful features to redirect Urls.  Sometimes these features can interfere with legitimate Urls and redirect them to invalid Urls.  If you're getting a 404, check to see that the Url with the 404 error is the same one that you clicked on or entered in.  If it isn't, it might be being redirected to an invalid Url.  You can also check this by monitoring the Http Traffic with a free tool like Microsoft Fiddler.  This will immediately show you if the Url has a 302 or 301 redirect to an invalid Url.

If you are getting an unwanted redirect, you may be able to prevent it by adding to the value in the 'doNotRedirect' regex field.

- Check for Custom 404 Handlers

Some third-party DNN modules implement customised 404 handlers, which are used to capture any request that doesn't match a DNN page, and then redirect that Url to a different page.  Sometimes these redirections capture the wrong url and redirect them incorrectly.  If you have custom 404 error handlers defined in your web.config file, then consider removing these and see if it fixes the problem.

- Check wildcard Mapping

The Url Master module contains a feature which allows you to run your DNN site with no page extensions at all.  To do this, you need to 'wildcard map' all page extensions to the runtime engine.  In IIS7, this is handled by the module directly.  If you're using IIS6, then you need to change the IIS configuration.  If this change hasn't been performed (and you've switched on the 'no page extension' option) then this will cause 404 errors.  If you have performed the change in IIS6, double check to make sure you didn't click the option of 'check file exists'.  This option must be set to False.

- Check Custom Urls

If you've used the 'Admin->Page Urls' page to enter a custom Url for your page, double-check the value to see it is correct.  A common mistake is to try and add a blank Url for the site home page, to try and get the Url to display the site root instead of home.aspx (ie instead of   This is incorrect and will result in problems with login, privacy and other links on the home page. 

To make the home page Url a site root, all you need to do is go into the site settings page, and select the home page in the 'home' page drop down (in Site settings->Advanced Settings).  This will automatically generate the page as the site root.

If you've mistyped a Custom url or redirect, it might be causing a 404 error.

- Check for existences of physical files, or the path of the Url for images, css files etc

Sometimes, when a change is made to use Friendly Urls, some relative paths of modules/pages/images/css files/js files no longer work correctly.  This can be ascertained by viewing the Url of an incorrect link, and checking whether the path is valid.  If it isn't, you may have to change how that Url has been generated, and use a method that doesn't rely on the relative path. 

- Check for + encoding on IIS7 installs.

IIS7 includes a security update that doesn't allow for + signs to be included in the path of a Url.  See for more details.

- Do a Fiddler Trace

If all else fails, please try and do a fiddler trace of your page, and post the details in the product support forum.


 |  View Topic History  |