Products » Support Forums 

Support Forums

HomeHomeDotNetNuke Modu...DotNetNuke Modu...Friendly Url Pr...Friendly Url Pr...4.7 and Ultramedia4.7 and Ultramedia
Previous
 
Next
New Post
11/14/2008 7:45 AM
 

I had version 4.6 and everything works fine. With 4.7 the http://www.bizmodules.net/   Ultra Photo Gallery doesn't work.  I tried excluding .swf and /desktopmodules/ but nothing seems to fix it. Reverted back to v4.6, all works fine. They have spaces in dir name but that didn't bother v4.6.  /DesktopModules/BizModules - UltraPhotoGallery/UltraPhotoGallery.swf

You can see it work here under 4.6 http://oasiscruise.com/Photo-Albums/Vancouver-Island/

Clicking on a picture will give you a url like this (fine in 4.6) http://oasiscruise.com/DesktopModules/BizModules%20-%20UltraPhotoGallery/Exif.aspx?alias=oasiscruise.com&Id=60&Src=/Portals/0/UltraPhotoGallery/1124/3/large/Victoria-3.jpg

Any idea why v4.7 is broken?

 
New Post
11/14/2008 9:39 PM
 

There is quite a lot of difference between 4.6 and 4.7 - too many to list - right down to one is in VB and the other in C#.  So I can't accurately say why one would work and the other not.

When you say 'doesn't work' can you be more specific?  Were you getting 404 errors, photos not displaying in slideshows, or something else?

Can you try using this value for the 'ignoreFileTypesRegex' attribute and see if it helps?

 

ignoreFileTypesRegex="(?<!linkclick\.aspx.+)(?:\.pdf$|\.gif$|\.png$|\.css$|\.js$|(?<!exif\.aspx.+)\.jpg$|\.html|\.htm|\.axd|\.swf$|\.flv$"

 
New Post
11/17/2008 11:20 PM
 

I think there are some brackets or something missing in that ignore... statement as it totally destroys the page layout, menus, pictures on all pages.

So added swf and flv in same format as original file. This still has same problem. The "player" appears to load, as you see the % loading but doesn't show. In other words, the flash player doesn't load or show. There is just "nothing" where the flash player should be but rest of page is fine. In FireFox page info get this:
/DesktopModules/BizModules - UltraPhotoGallery/UltraPhotoGallery.swf
application/x-shockwave-flash
0px × 0px

The page just never seems to complete loading? I thought this doNotRewriteRegex="(\.axd)|(/DesktopModules/)" told it not to do anything in desktopmodules dir or subdirs?

Do I need to add .xml as there are some of those in that directory. As I said the flash player loads in 4.6 no problem.

 
New Post
11/19/2008 1:17 AM
 

Hi John

Sorry, yes there is a missing bracket in the statement, a copy/paste error on my part.

Here it is again with the bracket corrected:

ignoreFileTypesRegex="(?<!linkclick\.aspx.+)(?:\.pdf$|\.gif$|\.png$|\.css$|\.js$|(?<!exif\.aspx.+)\.jpg$|\.html|\.htm|\.axd|\.swf$|\.flv$|/ajaxpro/)"

You will note that I added /ajaxpro/ to this as well - this (should?) fix the problems with the player.  I believe the issue is some of hte required javascript isn't being loaded when the player loads.  The player degrades gracefully enough, but it won't work as you found out.

 

 
New Post
11/20/2008 5:34 AM
 

Bruce, I looked through the IIS log files and found - I think this is where the errors start:
/ajaxpro/prototype.ashx --- with the new dll I get 404, with old a 200

I'll paste the errors, here but added g(ood), b(add) in front of entry - but other than that, they're identical? These are easier to compare without wordwrap ...

b2008-11-19 02:15:51 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /ajaxpro/prototype.ashx - 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/Photo-Albums/Vancouver-Island/ oasiscruise.com 404 0 0 1745 705 718
g2008-11-19 02:10:56 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /ajaxpro/prototype.ashx - 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/Photo-Albums/Vancouver-Island/ oasiscruise.com 200 0 0 4087 606 203
2008-11-19 02:15:52 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /ajaxpro/converter.ashx - 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/Photo-Albums/Vancouver-Island/ oasiscruise.com 404 0 0 1745 704 687
2008-11-19 02:15:52 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /ajaxpro/core.ashx - 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/Photo-Albums/Vancouver-Island/ oasiscruise.com 404 0 0 1740 700 703
2008-11-19 02:15:54 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /ajaxpro/BizModules.UltraPhotoGallery.AjaxDotNetForLightBox,BizModules.UltraPhotoGallery.ashx - 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/Photo-Albums/Vancouver-Island/ oasiscruise.com 404 0 0 1815 775 703
g2008-11-19 02:15:58 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /Portals/0/UltraPhotoGallery/1124/Cache/UltraPhotoGallery.xml 18191556 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/DesktopModules/BizModules%20-%20UltraPhotoGallery/UltraPhotoGallery.swf oasiscruise.com 200 0 0 9390 722 312
b2008-11-19 02:11:36 W3SVC1905202819 IPDMHZ0189MIA 66.132.186.41 GET /Portals/0/UltraPhotoGallery/1124/Cache/UltraPhotoGallery.xml 18191134 80 - 209.89.226.142 HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.0.3705;+.NET+CLR+1.1.4322;+Media+Center+PC+4.0;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+Alexa+Toolbar;+.NET+CLR+3.0.04506.648;+.NET+CLR+3.5.21022) .ASPXANONYMOUS=XFQsyet_yQEkAAAANDY2Y2YzM2QtOWFhYi00ZTM4LTkyYzgtYTk5Mzk5NDBhOGRk0;+_csuid=49228092241805cd;+language=en-US;+authentication= http://oasiscruise.com/DesktopModules/BizModules%20-%20UltraPhotoGallery/UltraPhotoGallery.swf oasiscruise.com 404 0 0 395 722 312
 

Yes the new ignore works but the photogallery still doesn't.

 
Previous
 
Next
HomeHomeDotNetNuke Modu...DotNetNuke Modu...Friendly Url Pr...Friendly Url Pr...4.7 and Ultramedia4.7 and Ultramedia


Support Guidelines.. Please read before posting

To get support on iFinity products and services, please search the forums for the the answer to the problem you are seeking. If you cannot find a solution, post a question in the relevant forum.   Ensure that you specify the relevant versions of the problem, and the actual error message or a detailed description of the problem.    You will need to register with this site to post on the forum.  If you have a Microsoft Live (Hotmail/Passport) account you can use that.  If you have a Open Id account you can use that.  If you neither of these, you will need to register a user Id and password.